Phone support

Support levels

There are three levels of support for phones in Compass:

  • Certified: the phone has been tested by IPerity to work with Compass. In addition, these phones are autoprovisioned by Compass.
  • Supported: the phone has been tested by IPerity to work with Compass. It has to be provisioned manually.
  • Known working: the phone has been reported to work by a partner.

Certified phones

Compass has fully certified phones from the following vendors for use with Compass:

  • SNOM
  • Yealink

SNOM

  • SNOM 710 (firmware 8.9.3.85)
  • SNOM D715 (>= 8.7.5.44, <= 8.9.3.80) - Note: firmware 10.1.17.0 is known broken with SRAPS
  • SNOM D725 (>= 8.7.5.44, <= 8.9.3.80) - Note: firmware 10.1.17.0 is known broken with SRAPS

The following phones are still supported, but End-Of-Life by the manufacturer. Support will be removed in a future version of Compass.

  • SNOM 300 (firmware 8.7.5.44) (EOL)
  • SNOM 320 (firmware 8.7.5.44) (EOL)
  • SNOM 360 (firmware 8.7.3.25.9) (EOL) - version 8.7.4.8.6 is needed to work with SRAPS (since 6-7-2018)
  • SNOM 370 (firmware 8.7.5.44) (EOL)
  • SNOM 720 (firmware 8.9.3.85) (EOL)
  • SNOM 760 (firmware 8.9.3.85) (EOL)
  • SNOM 870 (firmware 8.7.5.44) (EOL)

Yealink

  • Yealink SIP-T40P (firmware 54.81.188.7)
  • Yealink SIP-T42G (firmware 29.81.188.7)
  • Yealink SIP-T46G (firmware 28.81.188.7)

Please be aware that, due to a Yealink feature, setting custom configuration (e.g. function keys) via the phone's web user interface overrides auto provisioning, thus rendering any corresponding Compass settings obsolete.

Supported phones

The following phones have been tested with Compass and can be manually provisioned.

Polycom

  • Polycom VVX 300 (firmware 5.4.0.5841)
  • Polycom VVX 400 (firmware 5.4.0.5841)

Deprecated

The following phones have been previously available in Compass, but won’t be certified in future versions. Manually provision these phones if you want to continue to use them

  • SNOM M3 (can not be added since version 2017a, will be unprovisioned in 2017c or later)
  • SNOM M9 (can not be added since version 2017a, will be unprovisioned in 2017c or later)

Earlier support information

 

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.